WorkGroup View (GE)

Fields

Note

New WorkGroup View

This opens a new WorkGroup window in the Board.

  1. To create a new WorkGroup view,
    • In the Main Window, go to OptionsNew ViewWorkGroup (GE), or
    • In the Board, when a WorkGroup window is active, go to WorkGroupNew WorkGroup, or
    • Following a search for a WorkGroup record, drag-and-drop to the Board the WORKGROUP ( . ) root node of a tree resulting from the search, or double-click on it.

Note

Save As New WorkGroup

This saves the WorkGroup as a new entry in the database.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Save As New WorkGroup, or click the Save As New WorkGroup button in the button bar.

Note

Save As New Child WorkGroup

This saves the WorkGroup as a new entry in the database, with the current entry as a linked item.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Save As New Child WorkGroup, or click the Save As New Child WorkGroup button in the button bar.

Note

Save WorkGroup

This saves the WorkGroup in the database.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Save WorkGroup, or click the Save WorkGroup button in the button bar.

Note

Delete WorkGroup

This removes the WorkGroup from the database.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Delete WorkGroup.
  3. If you are sure you want to remove the WorkGroup from the database, Click OK.

Note

Refresh WorkGroup

This reverts the data for the WorkGroup to the version in the database.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Refresh WorkGroup.
  3. Click Refresh in the 'Are You Sure?' popup.

Close WorkGroup

This closes the window.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Close WorkGroup, or click the X button on the window's Title bar.

Note

Show All Cells

This shows all Fields, including the hidden ones, in the WorkGroup view.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Show all Cells.

Note

Show Lab Visible Cells

This hides the originally hidden Fields in the WorkGroup view; i.e., any fields hidden by a lab master, then revealed by Show all Cells, will again be hidden.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Show Lab Visible Cells.

Print Barcodes

This will print a barcoded label for this WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. On the WorkGroup menu click Print Barcodes.
  3. Select the type of barcode that you wish to create.
  4. Fill out the pop up.
    • Suffixes is a checkbox list of pre-defined words to add to the label, e.g. 'Forward Primers'.
    • User Data is a user-defined String that could be added to the label.
    • Barcode Printer is a list of barcode printers identified in Sesame.
    • No. of Copies is the number of copies of the barcode to print.
  5. Click the OK button to print.

Note

Create Primers

This creates primer sequences for amplifying ORFs.

  1. Make the WorkGroup window active in the Board.
  2. Highlight ORF(s) of interest by clicking on them. If no ORFs are selected, primers will be created for all in the Workgroup.
  3. On the WorkGroup menu click Create Primers.
  4. In the popup, fill in or check/uncheck fields as needed;
    • Min. Primer Length specifies the minimum length of the primers.
    • Max. Primer Length specifies the maximum length of the primers.
    • Min. Tm specifies the minimum calculated melting temperature of the primers and their reverse complements.
    • Max. Tm specifies the maximum calculated melting temperature of the primers and their reverse complements.
    • Tm Calculation is choice of formula for calculation.
      • Simple uses the standard approximation, where Tm = 2 * (#A + #T) + 4 * (#G + #C). # is the 'number of' operator.
      • Not So Simple uses the Simple approximation for sequences shorter than 14 nucleotides, and Tm = 64.9 + 41 * (#G + #C - 16.4) / (#A + #T + #G + #C) otherwise. # is the 'number of' operator.
    • 5' Prefix adds a sequence "prefix" to the 5' end of the primers generated. Prefixes are chosen by name from the dropdown menu. The sequences themselves are stored in Options → Lab Resources → 5' Prefix.
    • 3' Prefix adds a sequence "prefix" to the 3' end of the primers generated. Prefixes are chosen by name from the dropdown menu. The sequences themselves are stored in Options → Lab Resources → 3' Prefix.
    • Limit to 45 Bases limits the length of the primers to 45 bases or less.
    • Skip Start Codon leaves off the ORF start codon from the primer sequence.
    • Skip Stop Codon leaves off the ORF stop codon from the primer sequence.
    • Check for G or C end specifies that primers must have a G or C at each end.
    • Check GC Content 40-60% specifies that primers must have a GC content between 40% and 60%.
    • Check pair Tm difference < 5 specifies that the difference in melting temperature between primer pairs should be less than 5 degrees C.
    • Check for G or C end run > 3 in 5 rejects primers that have 3 or more Gs or Cs in the last 5 bases on each end.
    • Check for runs > 4 rejects primers with stretches of a single nucleotide that are more than 4 bases long.
    • Check for di-nucleotide runs > 4 rejects primers with 4 or more instances of 2 nucleotides in a row.
  5. Click the Create Primers button.
  6. A Primer Plate (prefix OQ) record will be created containing the primers and information about them. This can be saved and exported in various formats through Report.

Note

Create Protein Records

This creates a Protein (LA) record describing the purification of a protein.

  1. Make the WorkGroup window active in the Board.
  2. Highlight one or more ORFs in the ORF(s) table by clicking on them.
  3. In the WorkGroup menu click Create Protein Records.
  4. In the popup, fill in or check/uncheck fields as needed; typeable fields can also be filled later in the Protein record, but fields with checkboxes must be checked at this point to have Sesame perform the desired function.
    • Labfund is the source of funding used.
    • Status is a dropdown menu of Status options.
    • Type is a dropdown menu of Type options.
    • User Label is an additional label for the Workgroup.
    • Add Workgroup Path to User Label adds the IDs of the string of Workgroups leading to the current one.
    • Room is a dropdown list of Room locations.
    • Freezer is a dropdown list of Freezer locations.
    • Rack is a dropdown list of Rack locations.
    • Shelf is a dropdown list of Shelf locations.
    • Tower is a dropdown list of Tower locations.
    • Box is a dropdown list of Box locations.
    • ORF main id to Protein name transfers the content of the ORF record Main ID field to the Protein record name field.
    • ORF lab id to Protein name transfers the content of the ORF record Lab ID field to the Protein record name field.
    • Lab Protocol is the protocol followed to purify the protein.
    • Determine Cleaved Sequence calculates the Cleaved Sequence by making any changes specified by the Expression Vector choice.
    • Determine Uncleaved Sequence calculates the Uncleaved Sequence by making any changes specified by the Expression Vector choice.
    • Determine Quality Ctrl'd Sequence calculates the Quality Controlled cleaved sequence by making any changes specified by the Expression Vector choice AND any internal sequence changes specified in a linked Plasmid record.
    • Expression Vector is the identity of the Expression Vector, from a dropdown that becomes active once the Lab Protocol is chosen.
    • Labeling is the identity and percentage of any labeling (Semet, 15N and/or 13C labeling).
    • Protocol is the Protocol Tree; if allowed for a particular protocol, nodes can be added or subtracted at this point.
  5. Click the Create Protein Records button.

Note

Create Sample Records

This creates a Sample (JR) record describing the storage of a protein.

  1. Make the WorkGroup window active in the Board.
  2. Highlight one or more ORFs in the ORF(s) table by clicking on them.
  3. On the WorkGroup menu click Create Sample Records.
  4. In the popup, fill in or check/uncheck fields as needed; typeable fields can also be filled later in the Sample record, but fields with checkboxes must be checked at this point to have Sesame perform the desired function upon creating the Sample record.
    • Labfund is the source of funding used.
    • Status is a dropdown menu of Status options.
    • Type is a dropdown menu of Type options.
    • User Label is an additional label for the Workgroup.
    • Add Workgroup Path to User Label adds the IDs of the string of Workgroups leading to the current one.
    • Room is a dropdown list of Room locations.
    • Freezer is a dropdown list of Freezer locations.
    • Rack is a dropdown list of Rack locations.
    • Shelf is a dropdown list of Shelf locations.
    • Tower is a dropdown list of Tower locations.
    • Box is a dropdown list of Box locations.
    • ORF main id to Protein name transfers the content of the ORF record Main ID field to the Protein record name field.
    • ORF lab id to Protein name transfers the content of the ORF record Lab ID field to the Protein record name field.
    • Lab Protocol is the protocol followed to store the protein or to use it following storage.
    • Determine Cleaved Sequence calculates the Cleaved Sequence by making any changes specified by the Expression Vector choice.
    • Determine Uncleaved Sequence calculates the Uncleaved Sequence by making any changes specified by the Expression Vector choice.
    • Determine Quality Ctrl'd Sequence calculates the Quality Controlled cleaved sequence by making any changes specified by the Expression Vector choice AND any internal sequence changes specified in a linked Plasmid record..
    • Expression Vector is the identity of the Expression Vector, from the dropdown that becomes active once a Lab Protocol is chosen.
    • Labeling is the identity and percentage of any labeling (Semet, 15N and/or 13C labeling).
    • Protocol is the Protocol Tree; if allowed for a particular protocol, nodes can be added or subtracted at this point.
  5. Click the Create SampleRecords button.

Note

Show Visual Plate

This shows the positions of ORFs in the ORF List in plate form, e.g. if 96-well plate has been specified, the Visual Plate will show an 8 x 12 matrix [(A-H) x (1-12)] with the first ORF in the list in position A1, the second in A2, etc.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Show Visual Plate.

Show/Hide Columns

This allows columns in the ORF list to be hidden so that columns of interest can be more easily viewed, or to return those hidden columns to visibility.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Show/Hide Columns.
  3. Check or uncheck the boxes
    • If the box is unchecked, the field will be hidden.
  4. Click Set to confirm changes.

Count Selection

This returns the total number of ORFs in the table that have been selected.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Count Selection.

Invert ORF Selection

This reverses the current highlighted ORF selection, e.g. if rows A1 and A3 are selected, inverting the ORF selection will deselect these and select all others.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Invert ORF Selection.

Clear Selection

This clears selection from any currently highlighted ORFs.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Clear Selection.

Select Unique ORFs

This identifies repetition by highlighting only those ORFs in the table that are unique.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Select Unique ORFs.

Select Empty Wells

This selects any rows in the list that do not contain ORFs.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Select Empty Wells.

Load Selection

This allows selection of wells in a Workgroup using a file of Sesame well coordinates generated outside of Sesame (for example by an instrument).

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Load Selection.
  3. Browse for the file to be loaded, then choose either;
    • Wellcoord Lines if wells in the file are in the format of the Well Coordinate column of a Workgroup's ORF(s) field, i.e. wg#.plate#.well#, for example 9144.1.12.
    • Value per Well Lines if the file contains a value indicating selection/no selection for each well. Values can be '0, F, False, 1, T, True' (exactly as spelled here); the wells that correspond to 1, T, or True will be selected. The number of rows in the file should match the number of wells in the workgroup.

Reformat By Previous Coordinate

This allows reformatting of a child workgroup so that the positions of the ORFs carried down from a parent are the same; e.g. if an ORF was in position C8 in the parent Workgroup but is initially placed in A11 in the child because not all ORFs were carried down, it will be moved to C8.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Reformat By Previous Selection.
  3. Click OK in the popup.

Set Appendix On

This makes the Workgroup an Appendix, or terminal, workgroup. No child workgroups can be made from it.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Set Appendix On.

Set Appendix Off

This turns off the restriction that the Workgroup be a terminal workgroup to which no children can be added.

  1. Make the WorkGroup window active in the Board.
  2. On the Edit menu click Set Appendix Off.

Search ORFs By ID

Searches for ORFs within the Workgroup by ORF number, Main ID, Lab ID, or Protein Name.

  1. Make the WorkGroup window active in the Board.
  2. On the Search menu click ORFs By ID.
    • Fill in a search term or terms. When searching by ORF No, do not include the 'GO' prefix. Wildcard Characters are allowed.
  3. Press Search.

Note

Search ORFs By Characteristics

This searches for ORFs within the Workgroup by various characteristics like Source Organism and Residue Length.

  1. Make the WorkGroup window active in the Board.
  2. On the Search menu click ORFs By Characteristics.
    • Source Organism is the organism from which the ORF was obtained, e.g. Homo sapiens.
    • Residue Length is the number of amino acids making up the protein
    • Gcode Length is the number of nucleotides making up the gene sequence.
    • No of Introns is the number of introns in the ORF.
    • No of Cys is the number of cysteine residues in the ORF.
    • Molecular Weight is the molecular weight of the protein in Daltons.
    • PI is the isoelectric point of the protein.
    • Transmembrane Segments is the number of transmembrane segments known or thought to be present in the protein.
    • Heat is a measure, used by CESG, of the importance of a protein, as measured by citations.
    • Compound Operator is a setting that restricts results to those that satisfy ALL of multiple search terms (AND) or ANY of multiple search terms (OR).

Note

Search ORFs By Action

This searches the ORFs in the current Workgroup by the Actions attached to them.

  1. Make the WorkGroup window active in the Board.
  2. On the Search menu click ORFs By Action.
    • Position is a dropdown list with choices 'Any' and 'Last' which specifies searching any of the actions OR only the final one attached to each ORF.
    • Start Date limits the action searched by setting an earliest date when the action might have been applied.
    • End Date limits the action searched by setting a latest date when the action might have been applied.
    • Source Organism limits the search to the Source Organism specified.
    • Action Lab Protocol is a dropdown list of Lab Protocols under which actions may have been applied, and limits the search to the protocol specified.
    • Include Retired Actions indicates that actions that are no longer used should be searched as well as currently used actions.
    • Action Present Match is a dropdown with choices 'And' which specifies that ALL actions chosen must be present, and 'OR', which specifies that ANY of the actions chosen can be present.
    • Action Not Present Match is a dropdown with choices 'And' which specifies that ALL actions chosen must be absent, and 'OR', which specifies that the ANY of the actions chosen can be absent.
  3. Choose one or more actions as either 'Present' or 'Not Present' by checking boxes.
  4. Click Search.

Note

Generate Report for WorkGroup

This creates a text report for the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Generate Report for WorkGroup.

Note

Record XML Dump

This saves an XML report of the WorkGroup to the disk.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Record XML Dump.
  3. Fill out the pop up.
    • Inline DTD determines if the DTD (Document Type Definition) should be included in the File.
    • Formatting determines if new lines and spaces should be included in the File.
    • File Name defines the name of the File to be saved.
  4. Click the Save File button.

Note

Export ORFs to CSV (What You See)

For any ORF(s) chosen, this exports as a comma separated value (CSV) file the data shown in the ORF(s) table of a workgroup.

  1. Make the WorkGroup window active in the Board.
  2. Highlight ORFs of interest by clicking on them.
  3. In the Report menu click Export ORFs to CSV(What You See).
  4. In the popup, type a name for the file and choose a location for export.

Export ORFs to CSV (More Than You See)

For any ORF(s) chosen, this exports as a comma separated value (CSV) file the data uploaded to create an ORF record (see Bulk Load), including DNA sequence.

  1. Make the WorkGroup window active in the Board.
  2. Highlight ORFs of interest by clicking on them.
  3. In the Report menu click Export ORFs to CSV(More Than You See).
  4. In the popup, type a name for the file and choose a location for export.

Action Totals

This reports the actions applied in the Workgroup.

  1. Make the WorkGroup window active in the Board.
  2. In the popup, check the 'Show ORF No' and 'Show Well Coord' checkboxes if desired.
  3. In the Report menu click Action Totals.

ORF Actions

This reports all actions, upstream and downstream, applied to each ORF in the Workgroup.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click ORF Actions.

DB Reference Counts

This reports the databases and number of references to each database applied to each ORF in its External References field.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click DB Reference Counts.

Worklist

This creates a list of positions in a Source plate or plates [the parent Workgroup(s) of the current one] and corresponding positions in a Target Plate (the current one) to keep track of the transfer of samples to new positions.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Worklist.
    • Separator is a dropdown list of choices (Comma, Tab) for separating items in the report. This is relevant for reopening in a spreadsheet or other format.
    • Include Header is an indicator to include the column headers Source Plate, Source Well, Target Plate, Target WellVolume in the output file.
    • Well Coordinates is a dropdown of well coordinate orientations (1D or 2D) that will result in listing by A1, A2, B1, etc. or 1, 2, 3 etc.
    • Volume is the volume to be transferred.
  3. Click Report.

Note

Genomic Library Worklist

This creates a list of positions in a Genomic Library Source Plate and corresponding positions in a Target Plate (the current one) so that samples can be easily transferred to new positions. It uses as sources Genomic Libraries listed in Lab Resources → Genomic Libraries.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Worklist.
    • Separator is a dropdown list of choices (Comma, Tab) for separating items in the report. This is relevant for reopening in a spreadsheet or other format.
    • Include Header is an indicator to include the column headers Source Plate, Source Well, Target Plate, Target WellVolume in the output file.
    • Well Coordinates is a dropdown of well coordinate orientations (1D or 2D) that will result in listing by A1, A2, B1, etc. or 1, 2, 3 etc.
    • Volume is the volume to be transferred.
  3. Click Report.

Note

The report can be saved for reopening in another program by Table Report → Save Table File.

QIAGEN BioRobot Worklist

This creates a worklist that can be uploaded to a Qiagen liquid transfer BioRobot.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click QIAGEN BioRobot Worklist.
    • Volume is the volume in uL to be tranferred.
    • Source is the source(s) of the liquid to be transferred.
      • Source WG Plate is the ID of the parent Workgroup(s) of the current plate.
      • SSlot is a dropdown menu of locations on the robot where a Source WG Plate is located.
    • Destination is the target locations.
      • Destination WG Plate is the ID of the current plate.
      • DSlot is a dropdown menu of locations on the robot where a Destination WG Plate is located.

Note

Get ORF Genealogy

This creates a diagram tracing the path of a chosen ORF through all records, both upstream and downstream of the current Workgroup.

  1. Make the WorkGroup window active in the Board.
  2. Choose an ORF in the ORF(s) table by clicking on it.
  3. In the Report menu click Get ORF Genealogy.

Digestion Pattern

This creates a map of the predicted digestion pattern of an ORF nucleotide sequence by one or more restriction endonucleases. The map consists of a list of expected fragment sizes ordered from largest to smallest. If the restriction enzymes(s) do not cut the sequence, a single fragment size matching that of the full-length ORF will be shown.

  1. Make the WorkGroup window active in the Board.
  2. Choose an ORF in the ORF(s) table by clicking on it.
  3. In the Report menu click Digestion Pattern.
    • choose one or more restriction enzymes by filling the checkboxes.
  4. Click Report.

Note

Export Gcode

This exports the genetic codes of selected ORF records in the ORF(s) table as DNAStar Seqbuilder files.

  1. Make the WorkGroup window active in the Board.
  2. Highlight ORFs of interest in the ORF(s) table by clicking on them.
  3. In the Report menu click Export Gcode.
  4. In the popup, fill in fields;
    • Skip Start Codon - leave default 'Yes' to leave out an initial ATG start codon or change to 'No' to include it in the exported sequence.
    • Skip Stop Codon - leave default 'Yes' to leave out the last codon (presumably a TAG, TGA, TAA stop codon) or change to 'No' to include it in the exported sequence.
    • 5' Extension - to add plasmid-derived sequence onto the 5' end of the ORF sequence export, choose a plasmid name from the dropdown menu.
    • 3' Extension - to include plasmid-derived sequence onto the 3' end of the ORF sequence export, choose a plasmid name from the dropdown menu.
    • Output File Directory - to export files to a different location, alter the default location in this field.

Note

Caliper LabChip Input File

This creates a file to be used as input for the Caliber LabChip capillary electrophoresis instrument.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Caliper LabChip Input File.

Material Repository Files

This creates files with the information needed to accompany deposition of reagents (usually plasmid constructs) into the PSI Materials Repository.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Material Repository Files.

Retrace

This reports, for each ORF in the Workgroup, all records and actions added to them, back to the root Workgroup(s).

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Retrace.

NIH Selected

This reports whether or not the thread can be traced backward from the current Workgroup to the NIH action 'selected', whether that action is at the root of the thread, and whether Labfund is missing from any of the records.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click NIH Selected.

Roots And Branches

This creates a report showing all linked records from the current Workgroup's wells, both backwards to root Workgroup(s) and forward to all 'branch' records.

  1. Make the WorkGroup window active in the Board.
  2. In the Report menu click Roots and Branches.

Add Amount

This adds an amount to the WorkGroup balance.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Amount field.
  3. Enter values in 'Add Amount' popup.
    • Amount Added is the amount that will be added to the Amount Balance.
    • Unit is the unit for the Amount Change and the Amount Balance. The list of unit choices is maintained by the lab master.
    • Description is the reason for the change.
  4. Click OK in the 'Add Amount' popup.

Note

Subtract Amount

This subtracts an amount from the WorkGroup balance.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Amount field.
  3. Enter values in 'Subtract Amount' popup.
    • Amount Taken is the amount that will be subtracted from the Amount Balance.
    • Unit is the unit for the Amount Change and the Amount Balance. The list of unit choices is maintained by the lab master.
    • Description is the reason for the change.
  4. Click OK in the 'Subtract Amount' popup.

Note

Add External Reference

This adds a new row to the External Reference Field.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the External Reference Field.
  3. Enter data into the editable columns of the new row.
  4. The item must be saved before changes in the database occur.

Note

Display External Reference

This opens the selected row from the External Reference table in the default browser if there is a URL defined for it.

  1. Make the WorkGroup window active in the Board.
  2. Select a row in the External Reference Field, then click on the ICON button on the right side of the External Reference Field.

Note

Remove External Reference

This removes the selected row from the External Reference table.

  1. Make the WorkGroup window active in the Board.
  2. Select a row in the External Reference Field, then click on the ICON button on the right side of the External Reference Field.

Note

Add File

This uploads one or more Files from the disk and attaches them to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Files Field.
  3. Set the values in the 'Add Row' popup.
    • User Label is the User label.
    • Format determines if one or more Files will be added. To set it, click on the Field, then click the format that you want to use.
      • File if only the selected File will be added.
      • Folder if all the Files from the selected Folder will be added.
      • Folder with Subfolders if all the Files from the selected Folder and all the Subfolders will be added.
    • File Name is the name of the File or Folder depending on the selected Format. To set it, click on the Field, then set the values in the 'Select File' popup.
      • In the Look in drop-down, click the drive or Folder that contains the Files you want to add.
      • Specify whether the Format is a File, Folder, or Folder with Subfolders.
      • Click Select File.
    • File Type is a list of File Types maintained by the lab master.
  4. Click Add File.

Note

Add File from the Web

This takes a File from the Web and attaches it to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Files Field.
  3. Set the values in the 'Add Row' popup.
    • User Label is the User label.
    • URL is the Web address of the File. Only the HTTP URL scheme is supported, and it must include the 'http://' prefix.
    • File Type is a list of File Type maintained by the lab master.
  4. Click Add File.

Note

Display File in the Board

This displays a File attached to the WorkGroup in the Board.

  1. Make the WorkGroup window active in the Board.
  2. Alternatively, you can
    • select a File (a row) in the Files Field, then click on the ICON button on the right side of the Files Field, or
    • drag a File (a row) from the Files Field to an open area of the Board and drop it, or
    • double-click on a File (a row) in the Files Field.

Note

Display File in its Associated Application

This opens a File, attached to the WorkGroup, using its associated application .

  1. Make the WorkGroup window active in the Board.
  2. Alternatively, you can
    • select a File (a row) in the Files Field, then click on the ICON button on the right side of the Files Field, or
    • right-click on a File (a row) in the Files Field.
  3. Click OK in the the 'Open with...' popup.

Edit File User Label And Type

This updates the User Label and the File Type for a File attached to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Select a File (a row) in the Files Field, then click on the ICON button on the right side of the Files Field.
  3. Set the values in 'Edit File Information' popup.
    • User Label is the User label.
    • File Type is the Lab Resources File Type of the File.
  4. Click Update.

Note

Save File

This saves Files attached to the WorkGroup to the disk.

  1. Make the WorkGroup window active in the Board.
  2. Select a File (a row) in the Files Field, then click on the ICON button on the right side of the Files Field.
  3. If you want to save the File in a different Folder, locate and open the Folder, or, in the File Name box, type the name for the Folder.
  4. Click Save.

Note

Remove File

This removes a File from the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Select a File (a row) in the Files Field, then click on the ICON button on the right side of the Files Field.
  3. Click Remove File in the 'Are You Sure?' popup.

Note

Link File by Drag & Drop

This adds a File already attached to a record to the WorkGroup.

  1. Make the WorkGroup window visible in the Board.
  2. Make the record already containing the File active in the Board.
  3. Select a File (a row) in the Files Field of the other record, then drag and drop it into the WorkGroup window's Title bar.

Note

Add Image

This uploads one or more Images from the disk and attaches them to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Images Field.
  3. Set the values in the 'Add Row' popup.
    • User Label is the User label.
    • Format determines if one or more Images will be added. To set it, click on the Field, then click the format that you want to use.
      • File if only the selected Image will be added.
      • Folder if all the Images from the selected Folder will be added.
      • Folder with Subfolders if all the Images from the selected Folder and all the Subfolders will be added.
    • File Name is the name of the File or Folder depending on the selected Format. To set it, click on the Field, then set the values in the 'Select Image' popup.
      • In the Look in drop-down, click the drive or Folder that contains the Files you want to add.
      • Specify whether the Format is a File, Folder, or Folder with Subfolders.
      • Click Select Image.
  4. Click Add Image.

Note

Add Image from the Web

This takes an Image from the Web and attaches it to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Images Field.
  3. Set the values in the 'Add Row' popup.
    • User Label is the User label.
    • URL is the Web address of the Image. Only the HTTP URL scheme is supported, and it must include the 'http://' prefix.
  4. Click Add Image.

Note

Display Image in the Board

This displays an image attached to the WorkGroup in the Board.

  1. Make the WorkGroup window active in the Board.
  2. Alternatively, you can
    • select an Image (a row) in the Images Field, then click on the ICON button on the right side of the Images Field, or
    • drag an Image (a row) from the Images Field to an open area of the Board and drop it, or
    • double-click on an Image (a row) in the Images Field.

Note

Display Image in its Associated Application

This opens an Image attached to the WorkGroup using its associated application .

  1. Make the WorkGroup window active in the Board.
  2. Alternatively, you can
    • select an Image (a row) in the Images Field, then click on the ICON button on the right side of the Images Field, or
    • right-click on an Image (a row) in the Images Field.
  3. Click OK in the the 'Open with...' popup.

Edit Image User Label

This updates the User Label for an Image attached to the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Select an Image (a row) in the Images Field, then click on the ICON button on the right side of the Images Field.
  3. Set the values in 'Edit Image Information' popup.
    • User Label is the user label.
  4. Click Update.

Note

Save Image

This saves images attached to the WorkGroup to the disk.

  1. Make the WorkGroup window active in the Board.
  2. Select an Image (a row) in the Images Field, then click on the ICON button on the right side of the Images Field.
  3. If you want to save the Image in a different Folder, locate and open the Folder, or, in the File Name box, type the name for the Folder.
  4. Click Save.

Note

Remove Image

This removes an Image from the WorkGroup.

  1. Make the WorkGroup window active in the Board.
  2. Select an Image (a row) in the Images Field, then click on the ICON button on the right side of the Images Field.
  3. Click Remove Image in the 'Are You Sure?' popup.

Note

Link Image by Drag & Drop

This adds an Image already attached to another record to the WorkGroup.

  1. Make the WorkGroup window visible in the Board.
  2. Make active in the Board the record with the Image already attached.
  3. Select an Image (a row) in the Images Field of the other record, then drag and drop it into the WorkGroup window's Title bar.

Note

Add Info

This adds a new row to the Info table.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON button on the right side of the Info Field.
  3. Enter data into the editable columns of the new row.

Note

Remove Info

This removes the selected row from the Info table.

  1. Make the WorkGroup window active in the Board.
  2. Select a row in the Info Field, then click on the ICON button on the right side of the Info Field.
  3. Click Remove Info in the 'Are You Sure?' popup.

Note

Email Info

This emails the selected Info to the User who created the WorkGroup.

  1. Make the Employee Record window active in the Board.
  2. Select a row in the Info Field, then click on the ICON button on the right side of the Info Field.
  3. Click Send Email in the 'Are You Sure?' popup.

Note

Add Linked Item by Drag & Drop

This explicitly links an item to the WorkGroup.

  1. Make the WorkGroup window visible in the Board.
  2. Alternatively, you can
    • Drag and drop a tree node from the Search Results tree in the Main Window to the WorkGroup window's Title bar.
    • Drag and drop a row from the Linked Items Field of an Item already in the Board to the WorkGroup window's Title bar.
  3. Click Yes in the 'Are You Sure?' popup.

Note

Display Linked Item in the Board

This displays the Items linked to the WorkGroup in the Board.

  1. Make the WorkGroup window active in the Board.
  2. Alternatively, you can
    • select a row in the Linked Items Field, then click on the ICON button on the right side of the Linked Protocols Field, or
    • drag a row from the Linked Items Field to an open area of the Board and drop it, or
    • double-click on a row in the Linked Items Field.

Note

Unlink Linked Item

This removes an explicitly linked item from the Linked Items Field.

  1. Make the WorkGroup window active in the Board.
  2. Select a row in the Linked Items Field, then click on the ICON button on the right side of the Files Field.
  3. Click Unlink Item in the 'Are You Sure?' popup.

Note

Add ORF by Drag & Drop

There are three ways to add ORFs to a Workgroup.

  1. ORFs appearing in the main window following an ORF search can be added to a Workgroup one at a time by drag-and-drop to the title bar of the Workgroup, OR
  2. ORFs appearing in the Board following a search that sends results there (e.g. Search -> ORF (GO) -> By ID (Board)) can be selected and drag-and-dropped to the title bar of the Workgroup. Multiple ORFs can be added at once, including discontinuous selections from a list, OR
  3. ORFs can be selected in the ORF table of another Workgroup and drag-and-dropped to the title bar of a Workgroup. Multiple ORFs can be added at once, including discontinuous selections from a list. In this case the parent Workgroup and ORF coordinates in the parent Workgroup will be recorded in the new Workgroup.

Note

Add Action

This adds a new Action to the ORF or ORFs selected.

  1. Click on the ICON button on the right side of the Action Field.
  2. Choose an Action from the Add Action drop-down and click Add Action.

Note

Delete Action

This removes the most recently applied Action from the Action table.

  1. Make the Workgroup window active in the Board.
  2. Click on the ICON button on the right side of the Action Field.
  3. Click 'OK' in the 'Are you sure you want to remove the last Action?' popup.

Note

Show ORF

This opens an ORF record.

  1. Make the WorkGroup window active in the Board.
  2. Highlight an ORF by clicking on it.
  3. Click on ICON the symbol.

Note

Add Empty Row

This makes a new, empty, row which may serve as a placeholder or to move ORF rows to desired positions.

  1. Make the WorkGroup window active in the Board.
  2. Click on the ICON symbol.

Move Row Up

This moves a selected ORF up in the ORF table.

  1. Select the ORF(s) to be moved.
  2. Click the ICON button to move the row up.

Note

Move Row Down

This moves a selected ORF down in the ORF table.

  1. Select the ORF(s) to be moved.
  2. Click the ICON button to move the row down.

Note

Delete ORF From WorkGroup

This removes the ORF(s) from the WorkGroup.

  1. Highlight ORF(s) by clicking on it/them.
  2. Click the ICON symbol.

Note

Expand Protocol Tree Nodes

This expands all the nodes, starting from the selected node, in the Protocol Tree.

  1. Make the WorkGroup window active in the Board.
  2. Select a node by clicking on its name, then click the ICON button on the right side of the Protocol Tree Field.

Note

Collapse Protocol Tree Child Nodes

This collapses the child nodes of the selected node in the Protocol Tree.

  1. Make the WorkGroup window active in the Board.
  2. Select a node by clicking on its name, then click the ICON button on the right side of the Protocol Tree Field.

Note

Add Protocol Tree Child Node

This adds a child node to a selected node in the Protocol Tree. This is active only if the 'Tree Editable' option is checked in the Lab Protocol record in Lab ResourcesLab Protocol.

  1. Make the WorkGroup window active in the Board.
  2. If a Protocol Tree is present in the WorkGroup record after a Lab Protocol has been selected, select a node by clicking on its name, then click the ICON button on the right side of the Protocol Tree Field.
  3. If no Protocol Tree has been designed for the selected Lab Protocol, select the empty Field representing the root node by clicking on it, then click on the ICON button on the right side of the Protocol Tree Field.
  4. Fill in the Node Name Field.
  5. Choose Input or Output from the Node I/O Type drop-down.
  6. Click the 'Set' button

Note

Add Protocol Tree Sibling Node

This adds a sibling node (a node at the same level in the tree) to a selected node in the Protocol Tree. This is active only if the 'Tree Editable' option is checked in the Lab Protocol record in Lab ResourcesLab Protocol.

  1. Make the WorkGroup window active in the Board.
  2. Select a node by clicking on its name, then click the ICON button on the right side of the Protocol Tree Field.
  3. Fill in the Node Name Field.
  4. Choose Input or Output from the Node I/O Type drop-down.
  5. Click the 'Set' button

Note

Remove Protocol Tree Node

This removes the selected node from the Protocol Tree. This is active only if the 'Tree Editable' option is checked in the Lab Protocol record in Lab ResourcesLab Protocol.

  1. Make the WorkGroup window active in the Board.
  2. Select a node by clicking on its name, then click on the ICON button on the right side of the Protocol Tree Field.
  3. Click the 'Delete Node' button in the 'Do you really want to delete the node?' popup.

Note

See also